Jump to content


Photo

Elements 6 On Windows 7


  • Please log in to reply
3 replies to this topic

#1 mhm45

mhm45

    New Scrapper on the Block

  • Members
  • Pip
  • 21 posts
  • Gender:Female
  • Location:Toronto, Canada

Posted 16 November 2009 - 04:38 PM

Last week my computer (as my brother in England would put it) did a wobbler! That means is was misbehaving badly and freezing every 5-10 minutes. I took it in for surgery today and it is now running on Windows 7 (Ultimate). The bad side of this is that I now have to re-install all my programs. I am unable to get Elements 8 until after Christmas so I am wondering if it is all right to load Elements 6 onto the Windows 7 platform. Is it stll compatible?

Molly

#2 Vaughnde

Vaughnde

    Quietly Crochetin' and Scrappin'

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 31,085 posts
  • Gender:Female
  • Location:Roseburg, Oregon

Posted 16 November 2009 - 06:43 PM

I don't know Molly but my opinion is it should be. You can go to the PSE website on Adobe and find out if it is. I'm also bumping this up for others to see and answer :D
Posted Image

Posted ImagePosted ImagePosted ImagePosted Image

My SG Gallery My Blog I scrap with PSPX1

#3 MargotW

MargotW

    Scrap Girl Scrapper Devotee

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,447 posts
  • Gender:Female
  • Location:Buffalo, NY

Posted 17 November 2009 - 07:09 AM

Molly - My PSE7 works fine with WIN7. There wasn't that much difference between 6 & 7 so you shouldn't have a problem. Add-O-Matic will add your styles etc just fine in WIN7 also.
Posted Image


Posted ImagePosted ImagePosted ImagePosted ImagePosted Image
I shoot with a SONY A300 and scrap with PSE8

#4 mhm45

mhm45

    New Scrapper on the Block

  • Members
  • Pip
  • 21 posts
  • Gender:Female
  • Location:Toronto, Canada

Posted 17 November 2009 - 12:05 PM

Molly - My PSE7 works fine with WIN7. There wasn't that much difference between 6 & 7 so you shouldn't have a problem. Add-O-Matic will add your styles etc just fine in WIN7 also.


Thank you. I'm just about to try the install!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users