Terri M

Smart Objects In Pse 12 (And 11?)

6 posts in this topic

I upgraded to PSE 12 this week and generally like it quite a lot. But I had one weird thing going on, so I posted in the Adobe support forums this:

I upgraded from PSE 10 to PSE 12 this week and am confused about a change in behavior. I create a large blank document (3600x3600 pixels, scrapbook size) and then drag other items onto it to create new layers. In PSE10, the items I dragged in kept their original size. In PSE 12, they get resized to match the size of the document I'm dragging them on to. Is there a setting I need to change? Can't find it.

 

The response I got was:

For a few versions, including PSE 10, dragging up from the photo bin placed things as smart objects. In PSE 12 it places them normally, the same way a paste would do. If you want to duplicate the PSE 10 behavior, use file>place instead of dragging.

 

What is happening in PSE 12 is, when I dragged an embellishment from the photo bin onto my page, it would resize huge and cover the whole page. That didn't happen in PSE10.

 

I normally work by pulling a bunch of embellishments into my photo bin and then dragging them in. moving them around. To use file>place I have to find each one in its folder as I want to use it. This seems WAY harder to me.

 

I realize not many are on PSE 12, but I'm hoping PSE 11 works the same way and someone can help me. Can I place an embellishment as a smart object from a file I've already opened in PSE? Is there an easier way than going through the File menu?

Share this post


Link to post
Share on other sites

I work like you do, I drag a whole bunch of stuff into my bin and then double click on the item. It opens next to my layout and then I drag and drop from there. Never had a problem like that. I don't use the File Place as it takes to long and I'm lazy. I use PSE11 and love it. Sorry no help from me.

Share this post


Link to post
Share on other sites

I'm sure you have probably checked this but is your new document set to a resolution of 300ppi?

Share this post


Link to post
Share on other sites

Thanks, Belle, that's exactly the kind of tip I was looking for! Double click then drag --- I was using the File>Place and thinking, "This will take forever!"

Share this post


Link to post
Share on other sites

I know when this happens in Photoshop, it is something I can change in the preferences menu. Under Preferences> General, I can check or un-check "Resize Image During Place."

Share this post


Link to post
Share on other sites

Yeah, I found some posts from people with Photoshop that offered the preferences setting as a solution, but it doesn't seem to be something I get to control in Elements. I don't see it in any of my preferences screens :-(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now