Jump to content

Recommended Posts

Happy Sunday....

I just bought a new iMac that has operating system Catalina 10.15.7 version.  I use PSE 2019 and I can't get it to open.  It tries and says "loading" but then stops.  My question is Catalina compatible with PSE19?  Should I move on to PSE20 or PSE2021.  Are they compatible.  Any suggestions?

Thank you so much ...Laurie

Link to post
Share on other sites

I did a search asking if Mac OS Catalina was compatible with PhotoHop Elements 19.
I found THIS which talks about some issues between the two and says that PSE 20 & 21 will work with Catalina but has some known issues.  Since it doesn’t mention PSE 19, I’m wondering if that means that it isn’t compatible with that OS.

Ohhhh...  And, now I found THIS which also states,

“Older versions of Photoshop Elements and Premiere Elements contain some 32bit components which were not designed to work on macOS 10.15 Catalina. Older Elements versions were released prior to the Catalina OS release, which was released in October 2019.

Adobe recommends that customers using older versions of Photoshop Elements or Premiere Elements (versions 2019 or earlier) DO NOT upgrade to macOS 10.15 Catalina.”   So maybe the Operating System IS your issue?

I remember that the 32bit components (whatever they are) did cause other issues, but don’t remember what.   But, I DO remember I was told not to update to Catalina, as my 4 (now 5) year old MacBook Pro couldn’t handle it.....    

Link to post
Share on other sites

HERE is some more info.  Looks like Adobe recommended that you not upgrade to Catalina if you had PSE 19 or under.   But, since your computer is new, that doesn’t help you since it cam with it.    Sounds like your best bet would be PSE 20 or 21.

Link to post
Share on other sites

All the above!  I can tell you that my iMac was a total mess after it upgraded to the new version of Catalina.  It appears to have downloaded something that ran a program that bypassed google and caused the search engine to do yahoo.  I could not open a thing!  Everything was hosed up - LightRoom, Bridge, PSE, it took me days to figure it out.  Biggest mistake was upgrading (automatically.)  I lost my ability to use Picasa, most devastating!!

 

Link to post
Share on other sites
1 hour ago, SJDodd said:

All the above!  I can tell you that my iMac was a total mess after it upgraded to the new version of Catalina.  It appears to have downloaded something that ran a program that bypassed google and caused the search engine to do yahoo.  I could not open a thing!  Everything was hosed up - LightRoom, Bridge, PSE, it took me days to figure it out.  Biggest mistake was upgrading (automatically.)  I lost my ability to use Picasa, most devastating!!

Oh dear, I’m so sorry that happened to you.   But thank you for the information.   My MacBook Pro is now 5 years old running PSE13, but I remember having those same kinds of issues when I upgraded to Mojave.  

Link to post
Share on other sites
  • 2 weeks later...

New computer issues can be frustrating!!  I use the PS creative cloud (online version) so I haven't dealt with compatibility problems with my new MacBook.  Sorry this has happened.  Marilyn is always great with research and help links!  Good luck!

Link to post
Share on other sites
23 hours ago, SodScrap said:

New computer issues can be frustrating!!  I use the PS creative cloud (online version) so I haven't dealt with compatibility problems with my new MacBook.  Sorry this has happened.  Marilyn is always great with research and help links!  Good luck!

Thanks Conda!  I always wonder what the “Creative Cloud” is all about.  I keep getting Adobe emails and have no idea what that means.

Link to post
Share on other sites
9 hours ago, MariJ said:

Thanks Conda!  I always wonder what the “Creative Cloud” is all about.  I keep getting Adobe emails and have no idea what that means.

It gets confusing because people call it different things.  It's Photoshop, but the CC version???  

Link to post
Share on other sites
  • 4 weeks later...

I’ve only had a problem with my Cricut machine not working with 32 bit. I didn’t upgrade my iMac, so I’m hoping it won’t automatically update. I have not ok’d it so far, but don’t use my iMac much. If only MAC would tell us these things before we upgrade. I’d think letting us know our PSE 19 won’t work, and not give us an automatic upgrade stinks. I can’t use my PSE on mymlmacbook pro, but I think I can still use it on my iMac. I need to ensure it’s not upgraded yet.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...